4 Teknik Manajemen Bandwidth Dengan MikroTik

ngeBlog ModalSemangat 2016-07-01

Manajemen Bandwidth adalah teknik manajemen trafik jaringan komputer untuk pengaturan bandwidth sesuai profil yang diinginkan. Manajemen bandwidth digunakan untuk optimasi kinerja trafik jaringan, latency atau mengendalikan penggunaan bandwidth. Pada kesempatan ini saya akan mencontohkan implementasi Manajemen Bandwidth Dengan MikroTik.
  • Mengatur Bandwidth Menggunakan Simple Queue
  • Mengatur Bandwidth Menggunakan Queue Tree
  • Metode Pembagian Bandwidth Shared / Up To
  • Manajemen Bandwidth Berdasarkan Prioritas Trafik
Ada 2 fitur pada MikroTik untuk bagaimana mengatur bandwidth pada MikroTik :
  • Simple Queue - dirancang untuk mempermudah mengatur bandwidth untuk alamat IP tertentu dan / atau subnet.
  • Queue Tree - Untuk implementasi manajemen bandwidth lanjutan, membutuhkan marking packet pada fitur Mangle ( /ip firewall mangle). 
5 Teknik Manajemen Bandwidth Dengan MikroTik

Mengatur Bandwidth Menggunakan Simple Queue

Simple Queue adalah fitur / fungsi pada MikroTik RouterOS untuk membagi bandwidth komputer client yang sederhana dan paling mudah. Yang dapat menentukan kecepatan download dan upload maksimum berdasarkan IP Address komputer client. Contoh, kita akan menentukan kecepatan download dan upload maksimum untuk komputer yang mempunyai IP Address 192.168.0.6 sebesar : maksimum download 1mbps dan maksimum upload 512kbps. Di Winbox klik menu "Queue >> tab Simple Queues >> klik Add [+] 
Mengatur Bandwidth Menggunakan Simple Queue
Parameter Simple Queue :
  • Name : isi dengan nama user/komputer
  • Target : isi ip address client yang ingin dibatasi. Parameter ini bisa diisi dengan :
    • Single IP (192.168.0.6)
    • Network IP (192.168.0.0/24) IP client dari 192.168.0.2-192.168.0.254
    • IP lebih dari 1 (192.168.0.6,192.168.0.7) klik tombol panah bawah kecil di sebelah kanan kotak isian untuk menambahkan IP. 
  • Max Limit : [Target Upload] [Target Download] tentukan batasan bandwidth dengan memilih dengan klik drop down atau di ketik manual satuan bps (bit per second).
Dengan settingan seperti di atas, komputer client yang mempunyai IP address 192.168.0.6 akan mendapatkan maksimum kecepatan download 1mbps & upload 512kbps.

Mengatur Bandwidth Menggunakan Queue Tree

Pada Queue Tree implementasi manajemen bandwidth di mikrotik membutuhkan marking packet "matcher" pada fitur Mangle ( /ip firewall mangle). Jadi kita harus mendefinisikan sebuah koneksi terlebih dahulu dan menandainya (marking) agar bisa kita terapkan manajemen bandwidth untuk marking koneksi tersebut. Misalnya kita akan menandai koneksi/paket berdasarkan src-address (IP asal). Karena queueing pada Queue Tree mempunyai aliran paket secara satu arah. Jadi kita membuat marking untuk koneksi download & upload berdasarkan in-out interface gateway/internet, dan src-dst IP Address asal dan tujuan. Ribet yah? hehehe.
Saya ingin menandai paket dari komputer big boss yang mempunyai IP Address 192.168.0.3, dan saya beri nama "big_boss.down/up" yang nantinya mempunyai bandwidth/prioritas lebih besar dari karyawan lainnya. Dan karyawan lainnya saya tandai dengan nama "all_staff.down/up".  
Dari angan-angan tersebut, pertama kita buat mark packet download & upload si boss terlebih dahulu. IP >> Firewall >> Mangle
/ip firewall mangle add action=mark-packet chain=forward dst-address=192.168.0.3 in-interface=\     pppoe-speedy log-prefix="" new-packet-mark=big_boss.down passthrough=no add action=mark-packet chain=postrouting log-prefix="" new-packet-mark=big_boss.up \     out-interface=pppoe-speedy passthrough=no src-address=192.168.0.3
Mark Packet Koneksi Download
Mark Packet Koneksi Upload
Kedua, kita tandai paket download & upload komputer semua karyawan. IP >> Firewall >> Mangle
/ip firewall mangle add action=mark-packet chain=prerouting in-interface=pppoe-speedy log-prefix="" \     new-packet-mark=all_staff.down passthrough=no add action=mark-packet chain=postrouting log-prefix="" new-packet-mark=all_staff.up \     out-interface=pppoe-speedy passthrough=no
Mark Packet Koneksi Download
Mark Packet Koneksi Upload
Untuk in-out interface pada contoh ini saya menggunakan interface "pppoe-speedy" karena gateway internet saya ada di interface tersebut. Karena pada rules firewall mangle di mikrotik berlaku hirarki/urutan, jadi pada marking koneksi komputer karyawan saya tidak masukan lebih spesifik parameter src-address/dst-address nya. Karena pada baris 1 & 2 sudah ada marking untuk IP address si bos, jadi pada rules dibawahnya IP Address 192.168.0.3 akan diabaikan karena sudah diproses terlebih dahulu. Mikrotik akan menganggap pada mark packet "all_staff.up & all_staff.down " adalah paket koneksi download & upload semua IP Address selain 192.168.0.3. Setelah kita menandai koneksi seperti diatas, marking tersebut akan kita gunakan untuk mengatur bandwidthnya pada Queue Tree.
Skenarionya kantor saya punya total bandwidth internet 3Mbps dari ISP dan ingin mengalokasikan bandwidth internet untuk si bos 2Mbps dan semua karyawan 1Mbps. 
Implementasi yang digunakan untuk skenario diatas, akan seperti ini : 1) Queueing packet si boss
/queue tree add max-limit=2M name="Download Big Boss" packet-mark=big_boss.down parent=global queue=default add max-limit=2M name="Upload Big Boss" packet-mark=big_boss.up parent=global queue=default
Queue Tree
2) Queueing packet Karyawan
/queue tree add max-limit=1M name="Download All Staff" packet-mark=all_staff.down parent=global queue=default add max-limit=1M name="Upload All Staff" packet-mark=all_staff.up parent=global queue=default
Queue Tree
Parameter pada Queue Tree Parent : Pada parameter ini kita bisa tetapkan apakah queue ini adalah child queue. Packet Mark : Memilih packet mark yang sudah di buat di /IP Firewall Mangle Max Limit : Maksimal bandwidth yang bisa dicapai oleh paket yang di queue. Hasilnya sperti ini :
Queue Tree MikroTik
Secara umum begitulah manajemen bandwidth di mikrotik menggunakan Queue Tree, dengan teknik di atas kita bisa kembangkan misalnya prioritas bandwidth berdasarkan service / aplikasi jaringan (email, game online dll) karena dengan fungsi mangle kita bisa membedakan koneksi packet lebih spesifik.

Metode Pembagian Bandwidth Shared / Up To

Jika sebelumnya saya mencontohkan manajemen bandwidth dengan kecepatan yang tetap/fix, di bagian ini saya akan mencontohkan bagaimana manajemen bandwidth share di MikroTik
Contoh : Saya mempunyai bandwidth 2Mbps untuk dipakai 2 user. Jika 1 user aktif akan mendapatkan bandwidth full sebesar 2Mbps, dan ketika kedua user tersebut online akan terbagi otomatis menjadi masing-masing mendapatkan kecepatan 1Mbps.
Lanjut, kita akan menerapkan batasan per user menggunakan child-queue parent. Pada parameter limit per user kita tentukan Limit-at (CIR) dan Max Limit (MIR). Dan membuat queue parent dengan parameter Max-Limit (MIR) sebesar total bandwidth yang kita punya. Pertama kita setting master queue-parent.
Simple Queue Master Parent
Kemudian set queue user pada child-queue yang diarahkan ke Parent "Total Bandwidth", dengan parameter Limit-at 1Mbps dan Max-limit 2Mbps. Parameter pada opsi Limit-at bisa di artikan seperti garansi kapasitas bandwidth yang di dapat. Perhitungannya 2Mbps / 2 user = 1Mbps, jadi saat kecepatan total bandwidth memenuhi sebesar 2Mbps user tersebut akan dipastikan mendapatkan bandwitdh sebesar 1Mbps. Di contoh ini saya menggunakan "Simple Queue"
Simple Queue User Client
Simple Queue User Parent
Buat lagi untuk user lainnya. Hasilnya akan seperti ini : Pembagian Bandwidth Shared / Up ToHasil 1 - Saat hanya 1 user yang online, user tersebut mendapatkan semua total bandwidth Pembagian Bandwidth Shared / Up ToHasil 2 - Saat semua user online/download, masing-masing user mendapatkan rata 1MbpsTehnik diatas adalah pembagian bandwidth Shared / Up To, batasan bandwidth bertingkat (parent) dengan melakukan pembagian bandwidth secara merata.

Manajemen Bandwidth Berdasarkan Prioritas Trafik

Tehnik ke 4 ini adalah bagaimana menerapkan manajemen bandwidth berdasarkan prioritas trafik dengan identifikasi sebuah service/aplikasi jaringan.